当前位置:首页 > 问答

通达信至少连续N个周期

我来帮TA回答

如何设置通达信同时看一个股票的多个周期

点开多周期同列即可。

请高手帮忙编写通达信选股公式:M日内有N次连续涨停公式

{M 1 100 10} {N 1 50 3}
XG:COUNT(EVERY(C/REF(C,1)>=1.093 AND C=H,N),M)>=1;
通达信软件有选股不准确的毛病。
股票公式专家团为你解答,希望能帮到你,祝投资顺利。

求助通达信怎么多增加几个周期的K线图表按钮 比如3 分钟 2小时 4小时 软件自定的N来设置不好用

做不出来,按默认的足够了。
1分钟,5分钟,15分钟,30分钟,60分钟,4小时就是一个日K线图了。

某一条均线,连续 n 个交易周期保持“上涨” 或 “下跌 ”的指标公式。( 通达信软件)

maa:=ma(c,n);
EVERY(maa>ref(maa,1),m) or EVERY(maa<ref(maa,1),m);
把上述公式新建成选股公式,设置参数N 最小1最大1000缺省20(或自定)
设置参数M 最小1最大1000缺省20(或自定)

通达信副图怎样叠加指标

只能把2个指标源码编写到一块,这样才能叠加

请问怎么让这两个通达信指标叠加一起?

你的公式有问题啊
DIFF等重复定义.删除后面定义的.
以下为合并公式,但效果欠佳,不用为好.

◆短线操盘:EMA(C,13),COLORCD7F32,LINETHICK2;◆中级趋势:EMA(C,89),COLOR8C7853,LINETHICK1;◆长期趋势:EMA(C,89),COLOR4D4DFF,LINETHICK1;STICKLINE(C,H,L,0,0),COLORFF0000;STICKLINE(C>=O,C,O,2,1),COLORFF0000;STICKLINE(C<O,C,O,2,0),COLORFF0000;STICKLINE(C>=◆短线操盘,H,L,0,0),COLOR22FFFF;STICKLINE(C>=◆短线操盘 AND C>=O,C,O,2,0),COLOR22FFFF;STICKLINE(C>=◆短线操盘 AND C<O,C,O,2,1),COLOR22FFFF;STICKLINE(C>=◆中级趋势,H,L,0,0),COLORFF22FF;STICKLINE(C>=◆中级趋势 AND C>=O,C,O,2,0),COLORFF22FF;STICKLINE(C>=◆中级趋势 AND C<O,C,O,2,1),COLORFF22FF;STICKLINE(C>=◆长期趋势,H,L,0,0),COLOR2222FF;STICKLINE(C>=◆长期趋势 AND C>=O,C,O,2,0),COLOR2222FF;STICKLINE(C>=◆长期趋势 AND C<O,C,O,2,1),COLOR2222FF; MID : MA(CLOSE,20),LINETHICK1;UPPER: MID + 2*STD(CLOSE,20),LINETHICK1;LOWER: MID - 2*STD(CLOSE,20),LINETHICK1;DIFF:=( EMA(CLOSE,7) - EMA(CLOSE,19)); DEA:=EMA(DIFF,9); MACD:=0.90*(DIFF-DEA); TJ:=(DIFF>=DEA); TJ1:=(DIFF>=0); STICKLINE(TJ,H,L,0.5,0),COLORYELLOW; STICKLINE(TJ,O,C,4,0),COLORYELLOW; STICKLINE(TJ1 AND TJ,H,L,0.5,0),COLORF00FF0; STICKLINE(TJ1 AND TJ,O,C,4,1),COLORF00FF0; STICKLINE(DIFF<DEA,H,L,0.5,0),COLORF0F000; STICKLINE(DIFF<DEA,O,C,4,0),COLORF0F000; VAR1:=(CLOSE*2+HIGH+LOW)/4; SK:= EMA(VAR1,13)-EMA(VAR1,73); SD:= EMA(SK,2); DRAWTEXT((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 ) OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)) ,L*0.99,'~'),COLORGREEN; STICKLINE((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 ) OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)),H,L,0.5,0),COLORRED; STICKLINE((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 ) OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)),O,C,10,1),COLORRED;
红多绿空:EMA(CLOSE,13)*0.9993,COLORRED,LINETHICK0;
支撑线:EMA(CLOSE,55),COLORYELLOW,LINETHICK2;
压力线:EMA(CLOSE,89),COLORMAGENTA,LINETHICK2;
DEA1:=MA(MACD,5),LINETHICK2,COLORFF8080;
IF(DEA1>0,红多绿空,DRAWNULL),COLORRED,LINETHICK3;
IF(DEA1<0,红多绿空,DRAWNULL),COLOR00FF00,LINETHICK3;

(已经测试,复制可直接使用)